Esim Purchase issue in Asian region

Incident Report for ESIMCARD

Resolved

This incident has been resolved.
Posted Oct 08, 2024 - 01:27 EDT

Investigating

Following areas effected.
"Australia",
"Malaysia",
"Cambodia",
"Oman",
"Indonesia",
"Kuwait",
"Macau",
"Qatar",
"Thailand",
"Saudi Arabia",
Posted Oct 07, 2024 - 11:38 EDT
This incident affected: DATA eSim Purchase and DATA-VOICE eSim Purchase.