Package Purchase Outage for some countries

Incident Report for ESIMCARD

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 05:05 EST

Identified

We are experiencing an issue with some package purchases in the following countries:
1. Kuwait
2. Oman
3. Qatar
4. Saudia Arabia
Our team is working on a fix. We will provide updates shortly.
Posted Feb 08, 2025 - 02:50 EST
This incident affected: DATA eSim Purchase.