Asia ESIMs Purchase Issue

Incident Report for ESIMCARD

Resolved

This incident has been resolved.
Posted Sep 10, 2024 - 01:53 EDT

Update

Countries affected are :

South Korea
Hong kong
Macau
Singapore
Indonesia
Cambodia
China
Japan
Taiwan
Saudi Arabia
Qatar
Oman
Kuwait
Posted Sep 09, 2024 - 14:28 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2024 - 12:23 EDT

Investigating

We are currently investigating this issue.
Posted Sep 09, 2024 - 12:23 EDT
This incident affected: DATA eSim Purchase.