Esim Purchase Issues In Unlimited Bundles.

Incident Report for ESIMCARD

Resolved

This incident has been resolved.
Posted Oct 09, 2024 - 09:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2024 - 05:24 EDT

Investigating

Some of the Unlimited package are currently unavailable we are working on it please feel free to contact if you face any issues in any region.
Posted Oct 09, 2024 - 05:22 EDT
This incident affected: DATA eSim Purchase.